Debian Buster support

Buster (Debian 10) Package Available for Manticore search now.

Buster (Debian 10) package has been released into the Manticore Search packaging repository.

You can install now 3.1.0 version via the Debian 10 apt command:

$ wget https://github.com/manticoresoftware/manticoresearch/releases/download/3.1.0/manticore_3.1.0-190801-0a40d582-release.buster_amd64-bin.deb
$ sudo dpkg -i manticore_3.1.0-190801-0a40d582-release.buster_amd64-bin.deb

Or download distributive from the site.

For indexing from various sources or using the ICU processor the following optional dependencies can be installed:

$ sudo apt install libicu63 libmariadb3 libodbc1 libpq5 libexpat1

Leave a Reply

Training

Personal and team training will maximize them performance. 

Custom development

Need cone custom or individual features?

Fill the form and don’t forget to make the description of what you need.

Free config review

There are often optimizations that can be made to a Sphinx / Manticore setup by changing some simple directives in the configuration or making quick changes to an index definition.

Some common mistakes and issues can include:

  • doing main+delta without kill-lists, even if the delta does include updated records found in the main
  • using wildcarding with very short prefix/infix which can hammer performance in some cases
  • disabled (unintentional) seamless rotates and getting stalls on index rotations
  • adding texts as string attributes even if they are not using for any kind of operation (filtering, grouping, sorting) or mandatory to be present in results
  • using deprecated settings¬†

Having a quick look on the configuration can show issues or potential issues, this is why we want to offer a gift to our growing community!

When uploading your configuration file, we recommend to remove any database credentials first.

We suggest also you give as many possible details about your setup: how big is the data you have, how typical queries look and what issues you experience.

Contact us